Go4 v4.7.0 installation

/home/chibaj/go4-4.7.0.tar.gz   EURICAへ戻る

Go4v4.7.0 installtion

以下を実行

shell> tar xvf go4-4.7.0.tar.gz
shell> cd go4-4.7.0
shell> make all

install

Qt4のバージョンのため?

shell> make all でのエラーメッセージ (2015.08.13)

Producing bin/go4-config
Generating Makefile.qt
cd qt4/Go4GUI; /usr/lib64/qt4/bin/qmake go4gui.pro -o Makefile.qt "CONFIG+=release" "QMAKE_CXXFLAGS= -DLinux" "QMAKE_CXXFLAGS_RELEASE = -O2" "QMAKE_CFLAGS_RELEASE = -O2" "INCLUDEPATH+=/home/shu/root/include" "DEPENDPATH+=/home/shu/root/include" "QMAKE_LFLAGS += -Wl,--no-as-needed"  "LIBS+=-L/home/shu/root/lib -lGui -lCore -lCint -lRIO -lNet -lHist -lGraf -lGraf3d -lGpad -lTree -lRint -lPostscript -lMatrix -lPhysics -lMathCore -lThread -pthread -lm -ldl -rdynamic -lMinuit -lThread -lpthread -lXMLIO -lSpectrum -lASImage -lGed -lTreePlayer  -L/usr/X11R6/lib/ -lX11 -L/usr/lib/ -lX11 -L../../lib -lGo4Fit -lGo4Base -lGo4ThreadManager -lGo4TaskHandler -lGo4AnalBase -lGo4GUI" "unix:QMAKE_LFLAGS += -Wl,-rpath,/home/shu/root/lib -Wl,-rpath,/home/chibaj/go4-4.7.0/lib"
uic: File generated with too old version of Qt Designer
uic: File generated with too old version of Qt Designer
uic: File generated with too old version of Qt Designer
uic: File generated with too old version of Qt Designer
Generating Qt4 part of the MainGUI...
cd qt4/Go4GUI; make -f Makefile.qt
make[1]: ディレクトリ `/home/chibaj/go4-4.7.0/qt4/Go4GUI' に入ります
/usr/lib64/qt4/bin/uic TGo4ViewPanel.ui -o ui_TGo4ViewPanel.h
/usr/lib64/qt4/bin/uic TGo4StartClient.ui -o ui_TGo4StartClient.h
uic: File generated with too old version of Qt Designer
File 'TGo4StartClient.ui' is not valid
make[1]: *** [ui_TGo4StartClient.h] エラー 1
make[1]: ディレクトリ `/home/chibaj/go4-4.7.0/qt4/Go4GUI' から出ます
make: *** [bin/go4] エラー 2

Qt-4.8.6のインストール後に shell> make all
成功!(2015.08.13 17:45)

/home/chibaj/public_html/doku/data/pages/3research/riken/eurica/go4.7-1.txt · 最終更新: 2015/08/13 17:36 by junsei
www.chimeric.de Valid CSS Driven by DokuWiki do yourself a favour and use a real browser - get firefox!! Recent changes RSS feed Valid XHTML 1.0